vendredi 8 janvier 2016

Installation de l'IDE Arduino sous Linux Mint ou Ubuntu


Lorsque vous désirez installer un logiciel sous Ubuntu ou Linux Mint, on vous recommande généralement d'utiliser le "gestionnaire de logiciels" ou la "logithèque Ubuntu".  C'est simple, et ça garantit que l'application s'installe convenablement.  L'IDE Arduino est bel et bien disponible dans le gestionnaire de logiciels, mais il s'agit malheureusement de l'antique et désuète version 1.0.5  (elle date de mai 2013!).

Pour profiter des innombrables améliorations apportées au logiciel depuis cette antique version, il est nettement préférable d'installer manuellement la version la plus récente du logiciel.   Heureusement, ce n'est ni très long, ni très compliqué. Je vous propose donc cette petite marche à suivre.

N.B.:  Si votre intention est d'installer l'IDE Arduino sur un Raspberry Pi, il semble pour l'instant impossible d'installer autre chose que la version 1.0.5 (en écrivant "sudo apt-get install arduino" dans le terminal).  Les instructions ci-dessous ne fonctionnent pas pour le Raspberry Pi.

Désinstaller l'ancienne version

Si la version 1.0.5 de l'IDE Arduino est déjà présente sur votre ordinateur, il est préférable de la désinstaller.  Pour ce faire, allez dans la logithèque Ubuntu ou le gestionnaire de logiciels de Linux Mint, faites une recherche pour "Arduino" et cliquez sur le bouton "Suppression".  Ne vous inquiétez pas:  vos sketchs et les bibliothèques que vous avez vous-mêmes installées demeureront intacts à l'intérieur du répertoire que vous avez désigné comme "carnet de croquis".


Télécharger la nouvelles version

Vous vous dirigez ensuite sur la page web officielle de l'Arduino, et vous télécharger la version la plus récente conçue pour Linux (vous devez choisir entre 32 bits et 64 bits).



Décompression des fichiers

Le fichier que vous avez téléchargé est un fichier d'archive tar.xz.  Extrayez le répertoire qu'il contient à un endroit qui vous convient sur votre disque dur (l'emplacement exact n'est pas très important).


Script d'installation

Voici le répertoire suite à l'extraction.


À l'intérieur de ce répertoire , on trouve un script d'installation intitulé "install.sh". Si vous exécutez ce script, il va tenter d'installer un raccourci sur le bureau, et un lien vers l'application dans le menu de démarrage.

Sous Linux Mint, lorsque vous tentez d'ouvrir le fichier "intall.sh", il vous demande si vous désirez le lancer ou afficher son contenu:  cliquez sur le bouton "Lancer". 


Ensuite, allez vérifier si un raccourci est apparu sur le bureau...


...et si l'icône de l'application apparaît dans le menu de démarrage, dans la catégorie "Programmation" (étrangement, ça ne fonctionne pas toujours).



Sous Ubuntu, j'ai eu de la difficulté à exécuter le script (ils s'affichait obstinément dans un éditeur de texte au lieu de s'exécuter).  J'ai été obligé d'utiliser le terminal:

Naviguez d'abord jusqu'à l'intérieur du répertoire contenant le fichier "install.sh" au moyen de la commande "cd".

Ensuite, vous réglez les autorisations du fichier pour qu'il puisse être exécuté:

      chmod +x install.sh

...et vous exécutez le fichier:

      ./install.sh

Démarrage du logiciel

Peu importe que vous utilisiez le raccourci du bureau ou le lien dans le menu démarrer, vous devriez réussir à lancer le logiciel (si ça ne fonctionne pas...désolé...vous pouvez toujours retourner au gestionnaire de logiciels pour réinstaller la vieille version 1.0.5!).



Réglage de l'emplacement du carnet de croquis

Le carnet de croquis (ou sketchbook) est le répertoire où vous installez vos bibliothèques et enregistrez vos croquis/sketches/programmes.  Vous pouvez choisir l'emplacement de votre carnet de croquis dans les préférences (accessible par menu fichier).  C'est particulièrement important si vous désirez continuer d'utiliser le même carnet de croquis que vous utilisiez avec l'ancienne version de l'IDE.



Upload d'un sketch dans l'Arduino

Il ne vous reste plus qu'à télécharger un sketch dans votre Arduino, pour vérifier que tout fonctionne correctement.  




Si le téléchargement échoue avec une erreur du genre "Inappropriate ioctl for device":  pas de panique!  Il faut probablement vous ajouter au groupe "dialout".  Pour ce faire, vous ouvrez le terminal, et vous y écrivez la ligne suivante:

sudo usermod -aG dialout $(whoami)

J'ai dû ensuite redémarrer l'ordinateur pour que les changements prennent effet.

Ensuite, si vous écrivez  "groups" (toujour dans le terminal), ça vous présente une liste qui devrait contenir le mot "dialout".

Cette version à jour de l'IDE Arduino devrait maintenant être parfaitement fonctionnelle.

Yves Pelletier   (TwitterFacebook)

6 commentaires:

  1. Bonjour!

    Pour info, pour rendre un script executable, sous ubuntu, tu peux faire un "clic droit, propriétés" dessus, et il y a une case à cocher "autoriser l'execution du script..." ou un truc du genre !

    Sinon, dans la dernière version de l'IDE, il m'a proposé de m'ajouter au groupe "dialout" quand je l'ai lancé, mais ça n'a pas fonctionné, j'ai du effectivement le faire par la ligne de commande.

    RépondreSupprimer
    Réponses
    1. Dans mon cas, le fichier continuait de s'ouvrir dans un éditeur de texte alors que la case était cochée. Je suppose que quelque chose était déréglé ailleurs.

      Supprimer
  2. Merci pour ton tuto, as-tu essayé la même manip sur raspian ?

    RépondreSupprimer
  3. Un grand Merci pour ton tuto qui fonctionne sur Linux Mint Rosa 17.3 kde

    RépondreSupprimer
  4. Clair, simple, et ça marche du premier coup! (Mint 17.3) Un grand Merci!

    RépondreSupprimer
  5. Dans install.sh, remplacer RESOURCE_NAME=cc.arduino.arduinoide par RESOURCE_NAME=arduino-arduinoide pour la version 1.8.2

    RépondreSupprimer

Related Posts Plugin for WordPress, Blogger...